npm always crashes now with Cannot find module 'is-builtin-module'

local or global.

When I try to install is-built-in-module I get the same error. (haha)

When I try to clear cache I get the same error. I’ve tried various versions of node, currently on 10.15.3 (latest stable)

Any ideas?

I’m completely stuck. Can’t compile (webpack) or anything.

I removed and re-installed nodejs with n lts (10.15.3) which installed npm 6.4. then i updgraded to npm 6.9 and that seemed to do the trick. Whew!

Update May 7: I’ve now upgraded to node 12.2.0 which avoids the problem

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.