Not able to authenticate user on private npm registry (npm adduser fails with conflict).


(Shailesh Vaishampayan) #1

What I Wanted to Do

npm adduser --registry={my
_private_registry}

Tried deleting .npmrc in user’s directory and tried but same error.

What Happened Instead

I get
NMP ERR E409conflict
error message

Reproduction Steps

npm adduser --registry={my
_private_registry} using private npm registry. Doesnt work. get concflict error.
try deleting .npmrc from ~HOME/.npmrc and try again same error.

Details

I had previously logged into the registry suceessfully ussing old domain/machine password for our corporate network where registry is hosted. It worked. after that the password has expired for my machine and i am trying to login with new password which fails.
when i execute npm whoami --registry={same_privvate_registry_used_in_npm_adduser} it gives me info that you need to login and to be authenticated for this regisstry. it means i am currently not.

Platform Info

$ npm --versions
5.5.1
$ node -p process.platform
win32

(Kat Marchán) #2

This is a problem with the private registry afaict.


(Shailesh Vaishampayan) #3

What needs to be done then? do you mean I need to contact someone who setup this private registry?


(Kat Marchán) #4

Yep that’s pretty much all you can do, I think.


(system) #5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.