NODE_MODULE_VERSION Confusion


(Mickestroberg) #1

Hi!
Running the startup script for pol.is (Now using node v6.11.1 (npm v3.3.8) gives me the result below:

micke@fs_server:/var/www/html/bower_components/polisServer$ ./x
Running node v10.9.0 (npm v6.2.0)
internal/modules/cjs/loader.js:718
return process.dlopen(module, path.toNamespacedPath(filename));
^

Error: The module ‘/var/www/html/bower_components/polisServer/node_modules/bcrypt/lib/binding/bcrypt_lib.node’
was compiled against a different Node.js version using
NODE_MODULE_VERSION 48. This version of Node.js requires
NODE_MODULE_VERSION 64. Please try re-compiling or re-installing
the module (for instance, using npm rebuild or npm install).
at Object.Module._extensions…node (internal/modules/cjs/loader.js:718:18)
at Module.load (internal/modules/cjs/loader.js:599:32)
at tryModuleLoad (internal/modules/cjs/loader.js:538:12)
at Function.Module._load (internal/modules/cjs/loader.js:530:3)
at Module.require (internal/modules/cjs/loader.js:637:17)
at require (internal/modules/cjs/helpers.js:20:18)
at Object. (/var/www/html/bower_components/polisServer/node_modules/bcrypt/bcrypt.js:6:16)
at Module._compile (internal/modules/cjs/loader.js:689:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:700:10)
at Module.load (internal/modules/cjs/loader.js:599:32)
at tryModuleLoad (internal/modules/cjs/loader.js:538:12)
at Function.Module._load (internal/modules/cjs/loader.js:530:3)
at Module.require (internal/modules/cjs/loader.js:637:17)
at require (internal/modules/cjs/helpers.js:20:18)
at Object. (/var/www/html/bower_components/polisServer/server.js:18:16)
at Module._compile (internal/modules/cjs/loader.js:689:30)

Any suggestions on how to solve this?


(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.