node.js version for angular 4.4.6

Which one node.js version is compatible for angular 4.4.6? Because I have installed node.js 8.11.0 and trying to execute

npm install --save @angular/cli@4.4.6 npm install -g @angular/cli@4.4.6

getting error as below

npm ERR! code ETARGET npm ERR! notarget No matching version found for @angular/cli@4.4.6 npm ERR! notarget In most cases you or one of your dependencies are requesting npm ERR! notarget a package version that doesn’t exist.

Could you please suggest which version are compatible?

Thanks Amrut

I do not know which node version you need, but the npm error is telling you there is no version 4.4.6 of @angular/cli.

You can confirm this by going to https://www.npmjs.com/package/@angular/cli and clicking on the versions tab at the right hand side of the screen. There are 243 versions currently, but the numbers jump from 1.7.4 to 6.0.0.

Some other part of angular may be labelled 4.4.6, but it is not @angular/cli.

Thank you. I tried this as well. I am searching for the list of angular version and compatible node.js version but no luck till now.