node-gyp Visual Studio 2019 compatibility

Hi all!

The current version of node-gyp used by npm 3.8.0 which is not compatible with Visual Studio 2019. We had to change our production build machine until this package will be updated :( node-gyp is compatible with Visual Studio 2019 from its 5.0.0 version: nodejs/node-gyp#1747

Thank you!

See also: node-gyp v5.0.0 released

Great! Thank you! We have seen the thread is closed, is the team working on it? Can we help with some PR maybe?

@shadowspawn I have created a pull request for the two needed libraries (npm/cli and npm lifecycle):

https://github.com/npm/cli/pull/208
https://github.com/npm/npm-lifecycle/pull/38

Thanks, a PR will make it visible to the people who are managing the libraries.

FYI: I’m helping out on the forum, but not triaging code.

(I’ll move this topic to #development )

Thank you @shadowspawn I’m working on the PRs, I hope we can fix the problems soon. Sorry for disturb! :smiley:

1 Like