No valid versions available for onesait-ds- Can't install dependency and package not found


(Rory Deken) #1

What I Wanted to Do

I was trying to install a dependency

What Happened Instead

got the error No valid versions available for onesait-ds

Reproduction Steps

npm install onesait-ds didn’t work

Details

I searched for the package on npm https://www.npmjs.com/package/onesait-ds?activeTab=readme and this page is throwing a 404

Platform Info

$ npm --versions
<!-- paste output here -->
$ node -p process.platform
<!-- paste output here -->

(Lars Willighagen) #2

The package has been unpublished June 22nd (source):

{
    "_id": "onesait-ds",
    "_rev": "9-e1efe065575e4a7e60705cfbb59aab91",
    "name": "onesait-ds",
    "time": {
        "created": "2018-04-16T15:46:19.953Z",
        "1.0.0": "2018-04-16T15:46:20.204Z",
        "modified": "2018-06-22T15:40:34.455Z",
        "1.0.1": "2018-04-17T09:30:50.447Z",
        "1.0.2": "2018-04-17T10:29:08.648Z",
        "1.0.3": "2018-04-18T14:57:57.082Z",
        "1.0.4": "2018-04-20T08:54:01.121Z",
        "unpublished": {
            "name": "npm",
            "time": "2018-06-22T15:40:34.456Z",
            "tags": {
                "latest": "1.0.4"
            }
            ,
            "maintainers": [ {
                "name": "indivisual", "email": "carlosprat@gmail.com"
            }
            ],
            "versions": [ "1.0.0",
            "1.0.1",
            "1.0.2",
            "1.0.3",
            "1.0.4"]
        }
    }
    ,
    "_attachments": {}
}

Going off the README (cached version), the package was deprecated at least a month before removal.


(system) #3

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.