npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

“No spec found” is displayed after I use one jasmine reporter

I am using jasmine-node framework for my API automation. I am able to run REST services and able to get the result using node-fetch or http. Without reporter when I run with the below command I was able to get the results in console

jasmine spec/xxx.spec.js

After that I added a reporter(pretty html reporter) for reporting. Now when I run those commands, I get the below error.

No specs found

Below are my code for reporter.js

var Jasmine = require(‘jasmine’);
var HtmlReporter = require(‘jasmine-pretty-html-reporter’).Reporter;
var path=require(‘path’);
var jasmine = new Jasmine();


// options object
jasmine.addReporter(new HtmlReporter({
path: path.join(’./spec/helpers’,‘results’)


and jasmine.json is below

“spec_dir”: “spec”,
“spec_files”: [
“helpers”: [
“stopSpecOnExpectationFailure”: false,
“random”: true