No matching version found but package version is published

What I Wanted to Do

Trying to install packages to build BlueLightOS’s bluelight-base package for it’s repository.

What Happened Instead

Package version is not found.

Reproduction Steps

Try installing v0.1.77 of osjs-bluelight-installer-application.
It’ll fail but the website says it’s the current version.

Details

npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm ERR! code ETARGET
npm ERR! notarget No matching version found for osjs-bluelight-installer-application@^0.1.77
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! notarget 
npm ERR! notarget It was specified as a dependency of '@osjs/osjs'
npm ERR! notarget 

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/spaceboyross/.npm/_logs/2019-01-16T03_23_57_176Z-debug.log
==> ERROR: A failure occurred in package().
    Aborting...
[spaceboyross@spaceboyross bluelight-base]$ cd ..
[spaceboyross@spaceboyross pacman-repo]$ cd ..
[spaceboyross@spaceboyross Projects]$ cd OS.js
[spaceboyross@spaceboyross OS.js]$ git status
On branch v3
Your branch is up to date with 'origin/v3'.

Untracked files:
  (use "git add <file>..." to include in what will be committed)

	package-lock.json

nothing added to commit but untracked files present (use "git add" to track)
[spaceboyross@spaceboyross OS.js]$ npm outdated
Package                               Current  Wanted  Latest  Location
bluelight-settings-application         1.0.23  1.0.24  1.0.24  @osjs/osjs
osjs-bluelight-installer-application   0.1.72  0.1.77  0.1.77  @osjs/osjs
stylelint-scss                          3.5.0   3.5.1   3.5.1  @osjs/osjs
[spaceboyross@spaceboyross OS.js]$

Platform Info

$ npm --versions
{ '@osjs/osjs': '3.0.0-beta.7',
  npm: '6.5.0',
  ares: '1.15.0',
  cldr: '34.0',
  http_parser: '2.8.0',
  icu: '63.1',
  llhttp: '1.0.1',
  modules: '67',
  napi: '3',
  nghttp2: '1.35.1',
  node: '11.6.0',
  openssl: '1.1.1a',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.24.1',
  v8: '7.0.276.38-node.13',
  zlib: '1.2.11' }
$ node -p process.platform
linux

I’m experiencing the same issues for my recently published package: grunt-dart-sass. I received the email saying the package was published successfully and npmjs.com says the current version is up-to-date with my last publish, but I’m unable to install the latest version.

I’m sharing my recent post in a related forum. Somehow this issue has been resolved for me after hours of waiting and retrying, although I’m unsure of what caused the problem and what the fix was.

I’m thinking this has to do with caching like the package version is cached and it doesn’t detect the update so it doesn’t know about the latest version and just errors.

I’ve published a new version of pacote, which will fall back to the latest, full packument version, to sidestep some delays we occasionally experience with a worker that turns the full packument into the smaller packuments pacote consumes. This should solve most instances of this particular error, and will be available with the next npm release. Cheers!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.