npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

@ngx-translate/core@>=11.0.0 error

kan@iss-029:~/mypro/example$ npm install @ngx-translate/http-loader --save
example@0.0.0 /home/kan/mypro/example
├── UNMET PEER DEPENDENCY @ngx-translate/core@>=11.0.0
└── @ngx-translate/http-loader@4.0.0

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.7
npm WARN optional Skipping failed optional dependency /@angular/compiler-cli/chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.7
npm WARN @ngx-translate/http-loader@4.0.0 requires a peer of @ngx-translate/core@>=11.0.0 but none was installed.


Moved to #support, please use the bug template in the future.

To use @ngx-translate/http-loader you need to have @ngx-translate/core installed. The package signifies this by putting @ngx-translate/core in its peerDependencies. When installing, npm sees that you don’t have (the required version of) @ngx-translate/core installed, and warns you about it. This isn’t an error, and the install should be completed.