npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

ng new app --> npm ERR! cb() never called!

What I Wanted to Do

I want to create a new angular app without errors

Deseo crear una nueva aplicación en angular sin errores

What Happened Instead

The process stopped without giving any description only an error an log
npm ERR! cb() never called!

El proceso se detiene sin dar ninguna descripción solo el error y la dirección de los logs
npm ERR! cb() never called!

Reproduction Steps

I have install node and angular without problems but when I tried to create a new app in angular with ngnew app-name…, the process ends with a error

Instale el node y angular sin problemas pero cuando trato de crear una nueva aplicación en angular con el cli ng new nombre-app…, el proceso termina en error

Details

Here´s the logs file
Aca estan los logs

0 info it worked if it ends with ok
1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘install’,
1 verbose cli ‘–quiet’ ]
2 info using npm@6.4.1
3 info using node@v10.15.1
4 verbose npm-session d8bbcee97f76cd3c
5 silly install runPreinstallTopLevelLifecycles
6 silly preinstall eureka@0.0.0
7 info lifecycle eureka@0.0.0~preinstall: eureka@0.0.0
8 silly install loadCurrentTree
9 silly install readLocalPackageData
10 timing stage:loadCurrentTree Completed in 31ms
11 silly install loadIdealTree
12 silly install cloneCurrentTreeToIdealTree
13 timing stage:loadIdealTree:cloneCurrentTree Completed in 0ms
14 silly install loadShrinkwrap
15 timing stage:loadIdealTree:loadShrinkwrap Completed in 0ms
16 silly install loadAllDepsIntoIdealTree
17 http fetch GET 304 //registry.npmjs.org/@types%2Fjasmine 21110ms (from cache)
18 http fetch GET 304 //registry.npmjs.org/codelyzer 21109ms (from cache)
19 http fetch GET 304 //registry.npmjs.org/@types%2Fjasminewd2 21125ms (from cache)

1410 http fetch GET 304 //registry.npmjs.org/esrecurse 3453ms (from cache)
1411 silly pacote version manifest for @webassemblyjs/wasm-gen@1.7.11 fetched in 3594ms
1412 silly pacote version manifest for @webassemblyjs/wast-printer@1.7.11 fetched in 3547ms
1413 silly pacote range manifest for esrecurse@^4.1.0 fetched in 3531ms
1414 silly pacote range manifest for to-regex@^3.0.2 fetched in 31ms
1415 http fetch GET 304 ://registry.npmjs.org/estraverse 3031ms (from cache)
1416 silly pacote range manifest for estraverse@^4.1.1 fetched in 3031ms
1417 http fetch GET 304 ://registry.npmjs.org/remove-trailing-separator 5158ms (from cache)
1418 silly pacote range manifest for remove-trailing-separator@^1.0.1 fetched in 5174ms
1419 timing npm Completed in 120345ms
1420 error cb() never called!
1421 error This is an error with npm itself. Please report this error at:
1422 error https://npm.community

Platform Info

$ npm --versions
{ npm: '6.4.1',
  ares: '1.15.0',
  cldr: '33.1',
  http_parser: '2.8.0',
  icu: '62.1',
  modules: '64',
  napi: '3',
  nghttp2: '1.34.0',
  node: '10.15.1',
  openssl: '1.1.0j',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.23.2',
  v8: '6.8.275.32-node.12',
  zlib: '1.2.11' }

$ node -v
v10.15.1

I use win10 64bits and the node install for that win
Yo uso win10 64bits y la instalación de node para ese win


Try upgrading npm. There was an issue fixed in npm@6.6.0, and you should get a better error message now.
Intente actualizar npm. Se solucionó un problema en npm@6.6.0 y debería obtener un mejor mensaje de error ahora.

Very long topic:
Tema muy largo: