npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

Need help with npm issue

0 info it worked if it ends with ok
1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘install’,
1 verbose cli ‘C:\Users\kadom\Desktop\Desktop\homebridge-sense-master\package.json’ ]
2 info using npm@6.2.0
3 info using node@v10.9.0
4 verbose npm-session f7f22ab293707a71
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 timing npm Completed in 1274ms
8 error cb() never called!
9 error This is an error with npm itself. Please report this error at:
10 error
^ That’s the error message I get when executing npm install C:\Users\kadom\Desktop\Desktop\homebridge-sense-master\package.json

Likely related to [crash] npm ERR! cb() never called!

I’m new to source code and npm as a whole, so I couldnt figure out how to fix the issue from that guide. I have the most recent version and don’t know how to install the package. Any ideas? Thanks.

The gist of it, I think, is that the root cause for these cd() never called errors is still an elusive beast, and that at least one aspect of it appears to have something to do with the fact that the number of files that npm keeps simultaneously open can exceed the maximum your operating system will allow.

On macOS, Linux and the like it might pay off to investigate what this limit is (ulimit -Hn) and attempt to raise it (for macOS, this link might help:

In my case such investigations uncovered that somewhere in my bash startup sequence ( this limit was actually capped to a relatively low value whilst the system default was simply unlimited. Removing the capping ulimit -n ... line from that sequence is what fixed it for me.