Missing libraries can't be installed


(Thidasa Pankaja Paranavitharana) #1

I uninstalled eslint globally and trying to clear up my gloabl node modules.

I ran sudo npm list -g --depth 0 . Then I got something like this.

β”œβ”€β”€ @angular/cli@6.0.5
β”œβ”€β”€ @storybook/cli@3.3.15
β”œβ”€β”€ babel-eslint@8.2.3
β”œβ”€β”€ create-react-app@1.5.2
β”œβ”€β”€ create-react-native-app@1.0.0
β”œβ”€β”€ eslint-plugin-html@4.0.3
β”œβ”€β”€ eslint-plugin-prettier@2.6.0
β”œβ”€β”€ ethereumjs-testrpc@6.0.3
β”œβ”€β”€ firebase-tools@3.19.3
β”œβ”€β”€ gatsby-cli@1.1.50
β”œβ”€β”€ gitbook-cli@2.3.2
β”œβ”€β”€ gulp@3.9.1
β”œβ”€β”€ heroku-cli@6.16.18
β”œβ”€β”€ install@0.12.1
β”œβ”€β”€ jest@23.3.0
β”œβ”€β”€ jshint@2.9.5
β”œβ”€β”€ n@2.1.11
β”œβ”€β”€ nodemon@1.17.1
β”œβ”€β”€ now@11.2.5
β”œβ”€β”€ npm@5.6.0
β”œβ”€β”€ prettier@1.12.1
β”œβ”€β”€ react-devtools@3.2.1
β”œβ”€β”€ react-native-cli@2.0.1
β”œβ”€β”€ safe-buffer@5.1.2
β”œβ”€β”€ sequelize-cli@4.0.0
β”œβ”€β”€ serve@6.5.5
└── yarn@1.6.0

npm ERR! missing: safe-buffer@^5.1.2, required by minipass@2.3.3
npm ERR! missing: pacote@^8.1.6, required by libcipm@2.0.0
npm ERR! missing: read-package-json@^2.0.13, required by libcipm@2.0.0
npm ERR! missing: worker-farm@^1.6.0, required by libcipm@2.0.0
npm ERR! missing: lru-cache@^4.1.2, required by npm-registry-fetch@3.1.1
npm ERR! missing: lru-cache@^4.1.2, required by make-fetch-happen@4.0.1
npm ERR! missing: mississippi@^3.0.0, required by make-fetch-happen@4.0.1
npm ERR! missing: ssri@^6.0.0, required by make-fetch-happen@4.0.1
npm ERR! missing: lru-cache@^4.1.2, required by npm-registry-fetch@1.1.0
npm ERR! missing: lru-cache@^4.1.2, required by make-fetch-happen@3.0.0
npm ERR! missing: mississippi@^3.0.0, required by make-fetch-happen@3.0.0
npm ERR! invalid: once@1.3.3 /usr/local/lib/node_modules/npm/node_modules/mississippi/node_modules/end-of-stream/node_modules/once
npm ERR! missing: safe-buffer@^5.1.1, required by request@2.83.0
npm ERR! missing: readable-stream@^2.1.5, required by stream-iterate@1.2.0
npm ERR! invalid: string-width@1.0.2 /usr/local/lib/node_modules/npm/node_modules/update-notifier/node_modules/boxen/node_modules/ansi-align/node_modules/string-width
npm ERR! missing: strip-ansi@^3.0.0, required by string-width@1.0.2

Then I tried installing the required packages mentioned in missing packages errors. As an example I ran sudo npm install -g safe-buffer@^5.1.2 . It gets installed. But when I ran sudo npm list -g --depth 0 it still shows that it’s missing. How can I fix this ?


(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.