midi module compilation error


(Richard Foss) #1

I have been using the midi module for some time (thank you!). I have installed the latest version of node for the Mac (v8.12.0) and have needed to re-install all the node modules for my project. When installing ‘midi’, I get:

Error: The module ‘/Users/csrf/Documents/Immergo/ImmergoCode-SPK4-18-10-07/node_modules/midi/build/Release/midi.node’
was compiled against a different Node.js version using
NODE_MODULE_VERSION 57. This version of Node.js requires
NODE_MODULE_VERSION 51. Please try re-compiling or re-installing
the module (for instance, using npm rebuild ornpm install).

I did an npm rebuild, but got the same error.


(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.