issues in the package-lock.json.

Can’t fix this.
Can someone help?

npm ERR! code ELOCKVERIFY
npm ERR! Errors were found in your package-lock.json, run npm install to fix them.
npm ERR! Invalid: lock file’s macaddress@0.2.8 does not satisfy macaddress@^0.2.9

It looks like your package.json and package-lock.json are out of sync. The rules about which one wins when they are conflicts has changed, so there are different behaviours for different versions of npm.

A simple thing to try is recreating package-lock.json from what is in your package.json:

rm -rf node_modules
rm -f package-lock.json
npm install

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.