Issue: Error: Cannot find module 'hawk'


(Simon Legg) #1

MacOS 10.14.2
Node 8.11.3
npm 6.4.1

npm install returns error

npm ERR! code MODULE_NOT_FOUND
npm ERR! Cannot find module 'hawk'

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/simon.legg/.npm/_logs/2019-01-16T13_24_24_523Z-debug.log

I’m getting the same issue that https://github.com/npm/npm/issues/7218 describes. As asked in that issue I’ve uploaded the debug log as a gist here https://gist.github.com/leggsimon/784922e632bc883a8518c4afc8b26325

I’ve attempted npm install -g npm to update but get the same issue. It also happens on npm search <package>


(Atrian Wagner) #2

Since it is failing on a module, I’d recommend npm install --force.


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.