Is there any way to see what version of Node created a install tree?

I’ve recently come on to a project, and went to install all the packages. The project’s README said to use node v0.12.5. Wow. Outdated. I installed and used that version with NVM, and ran npm install. Nothing works. All the packages throw errors that they need newer things. Yeah, no kidding!

So I bump to Node v4. Same thing. Node v5. Same thing. Node v6 works, but the package-lock.json is showing lots of downgrades.

The only thing that seems to be missing are the versions of node and npm that were used to install and thus create the package-lock.json. Unless I’m missing something - is there some way to find that information?

If you have a package-lock.json, that got introduced in npm 5.0.0, so some version since then: https://github.com/npm/npm/releases/tag/v5.0.0

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.