Invalid config key requested: agentn

I am trying to update my version of Cypress to get the latest features by using
npm install --save-dev cypress@3.2.0

However, I repeatedly get the following error:

    Unhandled rejection Error: invalid config key requested: agentn f704669e418e9234
      at BadKeyError (/usr/local/lib/node_modules/npm/node_modules/figgy-pudding/index.js:93:23)
      at pudGet (/usr/local/lib/node_modules/npm/node_modules/figgy-pudding/index.js:101:5)
      at FiggyPudding.get (/usr/local/lib/node_modules/npm/node_modules/figgy-pudding/index.js:27:12)
      at Object.get (/usr/local/lib/node_modules/npm/node_modules/figgy-pudding/index.js:159:16)
      at new PacoteOptions (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/util/opt-check.js:9:21)
      at optCheck (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/util/opt-check.js:63:10)
      at Object.manifest (/usr/local/lib/node_modules/npm/node_modules/pacote/manifest.js:11:10)
      at fetchPackageMetadata (/usr/local/lib/node_modules/npm/lib/fetch-package-metadata.js:58:10)
      at limited (/usr/local/lib/node_modules/npm/node_modules/call-limit/call-limit.js:29:10)
      at /usr/local/lib/node_modules/npm/lib/install/deps.js:235:14
      at /usr/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:52:35
      at Array.forEach (<anonymous>)
      at /usr/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:52:11
      at Array.forEach (<anonymous>)
      at asyncMap (/usr/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:51:8)
      at exports.getAllMetadata (/usr/local/lib/node_modules/npm/lib/install/deps.js:206:3)

npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR!     <https://npm.community>

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/jaswindersingh/.npm/_logs/2019-03-15T13_32_59_565Z-debug.log

Does anyone know what this means, and how I can solve it?
I have never come across this error before?
Thanks.

What version of npm are you running?

@larsgw I’m currently using version 6.7.0. Thanks for your reply and hope that you can help me out with this issue because I’ve been absolutely stumped pulling my hair out as to what this error means and how I can resolve it!!

Others have had their issue closed, I tried to remove package-lock.json and node_modules folder and try and update my Cypress installation via npm, but keep getting the same error.
It’s not just cypress, its happening when I try and install “anything” from npm e.g nightwatch.

What config key is it exactly looking for, and where the error is?
And what exactly does ERR! cb() never called! actually mean??

Thanks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.