installing firebase tools with npm


(Abdalla19977) #1

trying to install firebase tools with npm using this command:

npm install -g firebase-tools

but i’m getting this error:

npm ERR! Unexpected end of JSON input while parsing near ‘…f6a",“dom-storage”: "^’

node version 10.15.1

npm version 6.4.1

windows 7

what i tried :

  1. unistall and install node
  2. using an older version of npm and node
  3. usingnpm cache clean --force

but nothing worked
is there any other way to install firebase tool without npm?othing worked


(Lars Willighagen) #2

There’s a status message.


(Abdalla19977) #3

solution i used a vpn app and then ran the command and it worked


(Lars Willighagen) closed #4