installation of angular-cli

What I Wanted to Do

I just want to install angular/cli
using command: npm install -g angular-cli

What Happened Instead

C:\Users\Windows>npm install -g angular-cli
‘CALL “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\
node_modules\npm\bin\npm-cli.js” prefix -g’ is not recognized as an
internal or external command,
operable program or batch file.
npm WARN deprecated angular-cli@1.0.0-beta.28.3: angular-cli has bee
n renamed to @angular/cli. Please update your dependencies.
npm WARN deprecated exists-sync@0.0.3: Please replace with usage of
fs.existsSync
npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on
reading Browserslist >3.0 config used in other tools.
npm WARN deprecated cryptiles@2.0.5: This version is no longer maint
ained. Please upgrade to the latest version.
npm WARN deprecated boom@2.10.1: This version is no longer maintaine
d. Please upgrade to the latest version.
npm WARN deprecated hoek@2.16.3: This version is no longer maintaine
d. Please upgrade to the latest version.
npm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - repla
ce it, following the guidelines at https://medium.com/gulpjs/gulp-ut
il-ca3b1f9f9ac5
npm WARN deprecated istanbul@0.4.3: This module is no longer maintai
ned, try this instead:
npm WARN deprecated npm i nyc
npm WARN deprecated Visit https://istanbul.js.org/integrations for o
ther alternatives.
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0
.2 or higher to avoid a RegExp DoS issue
[ …] | fetchMetadata: sill resolveWithNewModule cho
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error
at:
npm ERR! https://npm.community

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Windows\AppData\Roaming\npm-cache_logs\2019-0
3-27T19_40_46_470Z-debug.log

Reproduction Steps

2019-03-27T19_40_46_470Z-debug.log (162.8 KB)

I already updated by nodejs.

Details

Platform Info

$ npm --versions
<!-- paste output here -->
'CALL "C:\Program Files\nodejs\\node.exe" "C:\Program Files\nodejs\\
node_modules\npm\bin\npm-cli.js" prefix -g' is not recognized as an
internal or external command,
operable program or batch file.
**{ npm: '6.4.1',**
**  ares: '1.15.0',**
**  cldr: '33.1',**
**  http_parser: '2.8.0',**
**  icu: '62.1',**
**  modules: '64',**
**  napi: '3',**
**  nghttp2: '1.34.0',**
**  node: '10.15.3',**
**  openssl: '1.1.0j',**
**  tz: '2018e',**
**  unicode: '11.0',**
**  uv: '1.23.2',**
**  v8: '6.8.275.32-node.51',
**  zlib: '1.2.11' }**
$ node -p process.platform
<!-- paste output here -->
win32

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.