npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

I was told to report here...

I was trying to install saas. So i first installed node.js without having any problem.
However, when I tried to install saas, this issue has happend.

The terminal said:
TakashinoMBP:~ takashi$ npm install -g node sass

Unhandled rejection Error: EACCES: permission denied, mkdir ‘/Users/takashi/.npm/_cacache/index-v5/16/4a’

npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:

npm ERR! <>

npm ERR! A complete log of this run can be found in:

npm ERR! /Users/takashi/.npm/_logs/2019-03-27T09_12_29_717Z-debug.log

Thanks. There is an open issue with installing global packages using sudo leaving behind files with the wrong ownership.

The short version is run this to fix the ownership, then try your install again:

sudo chown -R $(whoami) ~/.npm

The long version and canonical bug is: Global installs (sudo npm i -g) fail on Mac after 6.5 upgrade. Works fine after 6.4.1 downgrade.

Thank you for your reply.

I just tried the short version, but it seems nothing has happened…

Now terminal says
finalize:sass: sill doSerial finalize 1504

pausing about 3min