i get error when i run npm install in webpack source code

cli
triaged

(Liu75675231) #1

What I Wanted to Do

i downloaded webpack source code ,url: https://github.com/webpack/webpack.git
and run npm install

What Happened Instead

npm WARN deprecated jade@1.11.0: Jade has been renamed to pug, please install the latest version of pug instead of jade
npm WARN deprecated constantinople@3.0.2: Please update to at least constantinople 3.1.1
npm WARN deprecated transformers@2.1.0: Deprecated, use jstransformer
npm WARN deprecated istanbul-lib-hook@1.2.1: 1.2.0 should have been a major version bump
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR! https://npm.community

Details

no npm-debug.log file generated

Platform Info

$ npm --versions
6.4.0
$ node -p process.platform
darwin

(Kat Marchán) #2

This is a duplicate of [crash] npm ERR! cb() never called!


(Kat Marchán) #3