i can't 'npm install' ?

npm install -g --unsafe-perm node-red@0.20.6

npm ERR! code ERR_OSSL_PEM_NO_START_LINE
npm ERR! error:0909006C:PEM routines:get_name:no start line

npm ERR! A complete log of this run can be found in:

help me!!!

i tried many methods

I do not recognise the error, so only some questions:

  • what version of npm are you using?
  • what version of node are you using?
  • what operating system are you running the commands on?
npm --versions
node -p process.platform

npm --versions
{
npm: ā€˜6.9.0ā€™,
ares: ā€˜1.15.0ā€™,
brotli: ā€˜1.0.7ā€™,
cldr: ā€˜35.1ā€™,
http_parser: ā€˜2.8.0ā€™,
icu: ā€˜64.2ā€™,
llhttp: ā€˜1.1.4ā€™,
modules: ā€˜72ā€™,
napi: ā€˜4ā€™,
nghttp2: ā€˜1.38.0ā€™,
node: ā€˜12.6.0ā€™,
openssl: ā€˜1.1.1cā€™,
tz: ā€˜2019aā€™,
unicode: ā€˜12.1ā€™,
uv: ā€˜1.30.1ā€™,
v8: ā€˜7.5.288.22-node.14ā€™,
zlib: ā€˜1.2.11ā€™
}
node -p process.platform
win32

running the commands

This report has same error and on Windows, but not a confirmed answer: https://stackoverflow.com/questions/55236936/how-can-i-solve-npm-err-error0909006cpem-in-node-js

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.