How to install https://github.com/bitpay/bitcore/tree/v8.0.0 ?


(Eduardo) #1

Hi.

I can install https://github.com/bitpay/bitcore (which install version 5.0 but after trying all the variations I haven’t been able to install version 8.0.0.

How can I install https://github.com/bitpay/bitcore/tree/v8.0.0 ?

Thanks.


(Markus Tacker) #2

You can’t install it using npm i, since this tree does not provide a valid package.json


(Eduardo) #3

Thanks for answering.

I have lost several days with this bitcore library. It’s like the developers don’t want anyone to use it. No documentation, no examples, no way to install it with npm. Amazing.


(Markus Tacker) #4

Well, the last installable version on npm is https://www.npmjs.com/package/bitcore/v/5.0.0-beta.44 , maybe v8 is not yet ready.


(Eduardo) #5

Thanks for your help.

V8 is in beta but they say that you can install it with npm install.

They don’t provide any docu, any sample code and didn’t bother to check that indeed it was possible to install it with npm.

In other words, they don’t give a damn about users.

Many times I think about the millions and millions of hours lost by developers cause library developers don’t bother to explain much or nothing at all and then one has to go to stackoverflow to beg for help.

Thanks.


(Eduardo) #6

I finally got help.

I download, extracted and then npm install path/to/library worked.

Thanks.


(system) #7

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.