How to get rid of "npm ERR! missing" and "npm ERR! extraneous"


(Janusz Dalecki) #1

Hi,

I have just started playing with the Angular2 using one of the examples that comes with the Book ANGULAR_2_BY_EXAMPLE.pdf (it’s a “angular2byexample-base” – downloaded from “https://github.com/chandermani/angular2byexample”).

I have updated the default package.json (using ncu -u) to the latest versions of all dependences:

{
"name": "trainer",
"version": "1.0.0",
"description": "Angular 2 implementation of Personal Trainer in TypeScript",
"repository": {
"type": "git",
"url": "git+https://github.com/chandermani/angular2byexample.git"
},
"bugs": {
"url": "https://github.com/chandermani/angular2byexample/issues"
},

"homepage": "https://github.com/chandermani/angular2byexample.git#readme",
"devDependencies": {
"@types/core-js": "2.5.0",
"del": "^3.0.0",
"gulp": "^3.9.0",
"gulp-connect": "^5.5.0",
"gulp-sourcemaps": "^2.6.4",
"gulp-typescript": "^5.0.0-alpha.3",
"gulp-watch": "^5.0.1",
"gulp-webserver": "^0.9.1",
"open": "0.0.5",
"typescript": "^3.0.1"
},
"dependencies": {
"@angular/common": "6.1.1",
"@angular/compiler": "6.1.1",
"@angular/core": "6.1.1",
"@angular/forms": "6.1.1",
"@angular/http": "6.1.1",
"@angular/platform-browser": "6.1.1",
"@angular/platform-browser-dynamic": "6.1.1",
"core-js": "^2.4.1",
"reflect-metadata": "0.1.12",
"rxjs": "6.2.2",
"systemjs": "0.21.4",
"zone.js": "^0.8.26"
},
"scripts": {}
}

Then I have used command “npm install” to install those dependencies.

Now when I run command “npm ls –depth=0” I get plenty of errors:

C:\tmp\Experiment2\angular2byexample-base\trainer>npm ls --depth=0

trainer@1.0.0 C:\tmp\Experiment2\angular2byexample-base\trainer
+-- @angular/common@6.1.1
+-- @angular/compiler@6.1.1
+-- @angular/core@6.1.1
+-- @angular/forms@6.1.1
+-- @angular/http@6.1.1
+-- @angular/platform-browser@6.1.1
+-- @angular/platform-browser-dynamic@6.1.1
+-- @types/core-js@2.5.0
+-- core-js@2.5.7
+-- del@3.0.0
+-- gulp@3.9.1
+-- gulp-connect@5.5.0
+-- gulp-sourcemaps@2.6.4
+-- gulp-typescript@5.0.0-alpha.3
+-- gulp-watch@5.0.1
+-- gulp-webserver@0.9.1
+-- open@0.0.5
+-- reflect-metadata@0.1.12
+-- rxjs@6.2.2
+-- systemjs@0.21.4
+-- typescript@3.0.1
`-- zone.js@0.8.26

npm ERR! missing: mkdirp@0.5.1, required by node-pre-gyp@0.10.0
npm ERR! missing: minimist@0.0.8, required by mkdirp@0.5.1
npm ERR! missing: minimatch@3.0.4, required by ignore-walk@3.0.1
npm ERR! missing: brace-expansion@1.1.11, required by minimatch@3.0.4
npm ERR! missing: balanced-match@1.0.0, required by brace-expansion@1.1.11
npm ERR! missing: concat-map@0.0.1, required by brace-expansion@1.1.11
npm ERR! missing: console-control-strings@1.1.0, required by npmlog@4.1.2
npm ERR! missing: inherits@2.0.3, required by readable-stream@2.3.6
npm ERR! missing: safe-buffer@5.1.1, required by readable-stream@2.3.6
npm ERR! missing: safe-buffer@5.1.1, required by string_decoder@1.1.1
npm ERR! missing: console-control-strings@1.1.0, required by gauge@2.7.4
npm ERR! missing: string-width@1.0.2, required by gauge@2.7.4
npm ERR! missing: strip-ansi@3.0.1, required by gauge@2.7.4
npm ERR! missing: code-point-at@1.1.0, required by string-width@1.0.2
npm ERR! missing: is-fullwidth-code-point@1.0.0, required by string-width@1.0.2
npm ERR! missing: strip-ansi@3.0.1, required by string-width@1.0.2
npm ERR! missing: number-is-nan@1.0.1, required by is-fullwidth-code-point@1.0.0
npm ERR! missing: ansi-regex@2.1.1, required by strip-ansi@3.0.1
npm ERR! missing: string-width@1.0.2, required by wide-align@1.1.2
npm ERR! missing: inherits@2.0.3, required by glob@7.1.2
npm ERR! missing: minimatch@3.0.4, required by glob@7.1.2
npm ERR! missing: once@1.4.0, required by glob@7.1.2
npm ERR! missing: once@1.4.0, required by inflight@1.0.6
npm ERR! missing: wrappy@1.0.2, required by inflight@1.0.6
npm ERR! missing: wrappy@1.0.2, required by once@1.4.0
npm ERR! missing: minipass@2.2.4, required by tar@4.4.1
npm ERR! missing: mkdirp@0.5.1, required by tar@4.4.1
npm ERR! missing: safe-buffer@5.1.1, required by tar@4.4.1
npm ERR! missing: yallist@3.0.2, required by tar@4.4.1
npm ERR! missing: minipass@2.2.4, required by fs-minipass@1.2.5
npm ERR! missing: safe-buffer@5.1.1, required by minipass@2.2.4
npm ERR! missing: yallist@3.0.2, required by minipass@2.2.4
npm ERR! missing: minipass@2.2.4, required by minizlib@1.1.0
npm ERR! extraneous: statuses@1.3.1 C:\tmp\Experiment2\angular2byexample-base\trainer\node_modules\gulp-webserver\node_modules\statuses

I have tried to find the solution using google but found nothing. There are some threads and discussions about similar problems but none of them works for me.

Can someone please help me with this one.

Regards,
Janusz


(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.