npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

Getting this error trying to install react on ubuntu

this is my first time using ubutun and trying to install react so that is why all i can do is paste all i find in the log. i need help ASAP.

0 info it worked if it ends with ok
1 verbose cli [ ‘/usr/bin/node’,
1 verbose cli ‘/usr/local/bin/npm’,
1 verbose cli ‘install’,
1 verbose cli ‘–save’,
1 verbose cli ‘–save-exact’,
1 verbose cli ‘–loglevel’,
1 verbose cli ‘error’,
1 verbose cli ‘react’,
1 verbose cli ‘react-dom’,
1 verbose cli ‘react-scripts’ ]
2 info using npm@6.10.0
3 info using node@v8.10.0
4 verbose npm-session 9fc7f181aef8000f
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 timing npm Completed in 6379ms
8 error cb() never called!
9 error This is an error with npm itself. Please report this error at:

Thanks


Do you have git installed?
Any other errors reported on command line when you run your command?


No I don’t and that is the only error i have seen for now


Out of ideas. Worked ok for me, and was a BIG install:
added 1546 packages from 744 contributors and audited 902137 packages in 151.596s