Getting error while installing package.


(Jenish Zinzuvadiya) #1

7753 verbose stack TypeError: err.code.match is not a function
7753 verbose stack at BB.try.catch.err (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\pacote\lib\with-tarball-stream.js:110:55)
7753 verbose stack at tryCatcher (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\bluebird\js\release\util.js:16:23)
7753 verbose stack at Promise._settlePromiseFromHandler (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\bluebird\js\release\promise.js:512:31)
7753 verbose stack at Promise._settlePromise (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\bluebird\js\release\promise.js:569:18)
7753 verbose stack at Promise._settlePromise0 (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\bluebird\js\release\promise.js:614:10)
7753 verbose stack at Promise._settlePromises (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\bluebird\js\release\promise.js:690:18)
7753 verbose stack at _drainQueueStep (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\bluebird\js\release\async.js:138:12)
7753 verbose stack at _drainQueue (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\bluebird\js\release\async.js:131:9)
7753 verbose stack at Async._drainQueues (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\bluebird\js\release\async.js:147:5)
7753 verbose stack at Immediate.Async.drainQueues [as _onImmediate] (C:\ProgramData\Microsoft\VisualStudio\MDA\c1a488cd\taco-toolset-6.3.1\node_modules\npm\node_modules\bluebird\js\release\async.js:17:14)
7753 verbose stack at runCallback (timers.js:705:18)
7753 verbose stack at tryOnImmediate (timers.js:676:5)
7753 verbose stack at processImmediate (timers.js:658:5)


(Lars Willighagen) #2

Please use the template for #bugs reports in the future. I moved your issue to #support, which allows more free-form posts.

Are you using Gulp 4.0 via GitHub by chance? If so, try changing the version from github:gulpjs/gulp#4.0 to github:gulpjs/gulp#semver:4.0, as per problem installing postcss-grid-kiss and gulp-postcss. If you have a different problem it is being hidden by a mistake in error handling, and we’d need more information to figure that out.