npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

Getting error on using npm install –g @angular/cli@latest

Hi I am using
npm -v
6.7.0

On running npm install –g @angular/cli@latest
I am getting the following error :

npm WARN registry Using stale data from http://registry.npmjs.org/ because the host is inaccessible – are you offline?
npm WARN registry Using stale data from http://registry.npmjs.org/ due to a request error during revalidation.
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR! https://npm.community

Please advice


(Just questions and not answers.)

Is it still reproducible? (Perhaps it was just a temporary outage.)

Are you behind a proxy server? (Common proxy and networking problems)

Lastly, and probably an editing issue rather than related, but just in case: when I copied and pasted your command I got an error and had to change the dash:

npm ERR! arg Argument starts with non-ascii dash, this is probably invalid: [ '–g', '@angular/cli@latest' ]
npm ERR! code EINVALIDTAGNAME