npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

Fehler bei Plugin Update

When updating a homebridge plugin i get the following error log.

0 info it worked if it ends with ok
1 verbose cli [ ‘/usr/local/bin/node’,
1 verbose cli ‘/usr/local/bin/npm’,
1 verbose cli ‘–no-update-notifier’,
1 verbose cli ‘install’,
1 verbose cli ‘–unsafe-perm’,
1 verbose cli ‘homebridge-config-ui-x@latest’ ]
2 info using npm@6.9.0
3 info using node@v11.2.0
4 verbose npm-session 61a344ab4571cf40
5 silly install loadCurrentTree
6 silly install readGlobalPackageData
7 timing npm Completed in 1956ms
8 error cb() never called!
9 error This is an error with npm itself. Please report this error at:
10 error

(Reports to #bugs should use the template which includes extra information like the npm version you are running and platform you are on. Reports to #support are more freeform and I have moved your issue there.)

I was not able to reproduce your problem running that command (I am on Mac). I don’t have any good suggestions.

Were there any other errors displayed when you ran the command?

Thanks for investigation.
I have made a screenshot. May this help:

Have nobody an idea? There is written it is an npm error itselve.


There is an open issue with installing global packages using sudo leaving behind files with the wrong ownership.

The short version is run this to fix the ownership, then try your install again:

sudo chown -R $(whoami) ~/.npm

The long version and canonical bug is: Global installs (sudo npm i -g) fail on Mac after 6.5 upgrade. Works fine after 6.4.1 downgrade.

Thank you,

i tryed this:
sudo chown -R homebridge ~/.npm

because of the user shown in the screenshot. Am I right? Because it did not work.
I get the same error message.

Yes, specifying homebridge is same as $(whoami) if user is homebridge.

  1. I do not think this is the answer, but is there a reason you are not installing it as a global package like in the example instructions on homepage?
sudo npm install -g --unsafe-perm homebridge-config-ui-x

(You may have been changing command trying to get it to work!)

  1. A question from the #bugs template. What platform are you on?
node -p process.platform

  1. Im running homebridge as a service according to the setup guide from If I try to run the update as user pi it works.
  2. linux


I am out of suggestions. (I do not understand enough about the homebridge environment to reproduce the pattern you are using.)

Good luck!