npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

ERROR: you cannot fetch versions for scoped packages

Not sure if this is strictly support but I have been using the registry API to get some information about installed packages and found that adding a version to a get request for a scoped package doesn’t work. For example https://registry.npmjs.org/@babel/core/latest returns with the error ERROR: you cannot fetch versions for scoped packages.

Is there a different way to fetch a version for a scoped package or will I just have to do the parsing of all the versions on my side?

Thanks!