error while creating new project using "ng" command

(santosh) #1

Getting below error while creating new project using ng command.

ng new frontend

silly pacote range manifest for caseless@~0.12.0 fetched in 70ms
http fetch GET 200 https://registry.npmjs.org/combined-stream 58ms
silly pacote range manifest for combined-stream@~1.0.6 fetched in 61ms
silly pacote range manifest for extend@~3.0.2 fetched in 0ms
timing npm Completed in 9992ms
error cb() never called!
error This is an error with npm itself. Please report this error at:
error <https://npm.community>

0 Likes

(John Gee) #2

Hi @santosh ! The “cb() never called!” is not the underlying error, and hopefully there is another error visible in the console or in the log.

There were some issues that were fixed in npm 6.6.0 to make sure all the errors get displayed, so if you have an older version then first step is to update.

0 Likes

(santosh) #3

Below is the complete error

node -v
v10.15.3
npm -version
6.4.1

Below is the complete error
gyp WARN install got an error, rolling back install

gyp ERR! configure error

gyp ERR! stack Error: EACCES: permission denied, mkdir ‘/usr/local/lib/node_modules/@angular/cli/node_modules/fsevents/.node-gyp’

gyp ERR! System Darwin 18.0.0

gyp ERR! command “/usr/local/bin/node” “/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “configure” “–fallback-to-build” “–module=/usr/local/lib/node_modules/@angular/cli/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64/fse.node” “–module_name=fse” “–module_path=/usr/local/lib/node_modules/@angular/cli/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64” “–napi_version=3” “–node_abi_napi=napi”

gyp ERR! cwd /usr/local/lib/node_modules/@angular/cli/node_modules/fsevents

gyp ERR! node -v v10.15.3

gyp ERR! node-gyp -v v3.8.0

gyp ERR! not ok

0 Likes

(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

0 Likes