Error when installing pg-native


(Coolraj80) #1

Hi,
I’m getting the following error message when attempting to install pg-native:

C:\Windows\system32>npm install pg-native

libpq@1.8.8 install C:\Windows\system32\node_modules\libpq
node-gyp rebuild

C:\Windows\system32\node_modules\libpq>if not defined npm_config_node_gyp (node
“C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bi
n\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Progra
m Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild )

MSBUILD : error MSB1009: Project file does not exist.
Switch: build/binding.sln
gyp ERR! build error
gyp ERR! stack Error: C:\Program Files (x86)\Microsoft Visual Studio\2017\Build Tools\MSBuild\15.0\Bin\MSBuild.exe failed with exit code: 1
gyp ERR! stack at ChildProcess.onExit (C:\Program Files\nodejs\node_modules
npm\node_modules\node-gyp\lib\build.js:262:23)


(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.