npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

error on NPM with Angular CLI

We are experiencing issues with installing angular cli. We’ve tried changing proxies and a variance of other support recommendations. We believe this is an issue between Google and NPM, however Google passes the buck like always to the third party.

We’ve tried uninstalling angular cli,
we’ve tried setting the proxy to null,
we’ve tried resetting the PRAM on the MacBook,
we’ve tried restarting the wifi
We don’t have a proxy installed
We’ve tried setting the npm registry to http.

It’s very frustrating. I’ve attached the ticket at the bottom of this post. as well I am going to paste the actual error that we are seeing. It fails on different packages but always to the same IP address.

npm WARN registry Unexpected warning for Miscellaneous Warning ETIMEDOUT: request to failed, reason: connect ETIMEDOUT

npm timing stage:rollbackFailedOptional Completed in 1ms
npm timing stage:runTopLevelLifecycles Completed in 1053628ms
npm verb type system
npm verb stack FetchError: request to failed, reason: connect ETIMEDOUT
npm verb stack at ClientRequest.req.on.err (/usr/local/lib/node_modules/npm/node_modules/node-fetch-npm/src/index.js:68:14)
npm verb stack at ClientRequest.emit (events.js:198:13)
npm verb stack at Socket.socketErrorListener (_http_client.js:392:9)
npm verb stack at Socket.emit (events.js:198:13)
npm verb stack at emitErrorNT (internal/streams/destroy.js:91:8)
npm verb stack at emitErrorAndCloseNT (internal/streams/destroy.js:59:3)
npm verb stack at process._tickCallback (internal/process/next_tick.js:63:19)
npm verb cwd /Users/chrisburd/Workspace/one
npm verb Darwin 19.0.0
npm verb argv “/usr/local/bin/node” “/usr/local/bin/npm” “install” “-g” “@angular/cli” “-verbose”
npm verb node v10.16.3

You mention angular in the title, but it looks like an issue reaching the npm registry. Can you install other packages, or are all installs failing in the same way?

There is a troubleshooting article including some basic steps checking the npm registry is reachable: Common proxy and networking problems

There are not any issues showing on:

It’s fixed now - something was wrong with that subnet block… I’m a CCIE by trade, the issues were socket errors and they were on the egress from the repository. I don’t really know what happened but at the end of the day, I don’t appreciate google not wanting to take ownership. Yes NPM is different, however - it is there service.

for the record I set the proxy to null, that didn’t do it many things didn’t fix the issue and it was wide spread amongst all of our machines. We even took the extraordinary steps of going to the Ohio State University and trying to hit the repository from there.

Not sure if we will hear what was broken. Glad it is working now!