Error installing curl-request

Hi Support,

I’m getting error while installing “curl-request”. Can you pls help?

npm ERR! Failed at the node-libcurl@1.3.3 install script
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2019-07-28T05_47_15_093Z-debug.log

2392 verbose stack Error: node-libcurl@1.3.3 install: `node-pre-gyp install --fallback-to-build`
2392 verbose stack Exit status 1
2392 verbose stack     at EventEmitter.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:301:16)
2392 verbose stack     at EventEmitter.emit (events.js:180:13)
2392 verbose stack     at ChildProcess.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
2392 verbose stack     at ChildProcess.emit (events.js:180:13)
2392 verbose stack     at maybeClose (internal/child_process.js:936:16)
2392 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:220:5)
2393 verbose pkgid node-libcurl@1.3.3
2394 verbose cwd /home/ec2-user/www/pets-api
2395 verbose Linux 4.14.133-113.105.amzn2.x86_64
2396 verbose argv "/usr/bin/node" "/bin/npm" "install" "curl-request"
2397 verbose node v9.11.2
2398 verbose npm  v6.10.1
2399 error code ELIFECYCLE
2400 error errno 1
2401 error node-libcurl@1.3.3 install: `node-pre-gyp install --fallback-to-build`
2401 error Exit status 1
2402 error Failed at the node-libcurl@1.3.3 install script.
2402 error This is probably not a problem with npm. There is likely additional logging output above.
2403 verbose exit [ 1, true ]

I do not think node-libcurl supports node 9 with a pre-built binary, so you might be running into problems attempting to build from source.

The latest version of this package has prebuilt binaries (thanks to node-pre-gyp) available for:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.