Error install npm

(kristof) #1

Hello,

i’m total new in npm so i get a lot of errors when i’m installing it

rgd

npm verb prepareGitDep undefined: installing devDeps and running prepare script.
npm ERR! prepareGitDep 1>
npm ERR! prepareGitDep > pre-commit@1.2.2 install C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\pre-commit
npm ERR! prepareGitDep > node install.js
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > spawn-sync@1.0.15 postinstall C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\spawn-sync
npm ERR! prepareGitDep > node postinstall
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > ngrok@2.1.8 postinstall C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\ngrok
npm ERR! prepareGitDep > node ./postinstall.js
npm ERR! prepareGitDep
npm ERR! prepareGitDep ngrok - downloading binary https://bin.equinox.io/a/chRZWPptE7w/ngrok-2.1.1-windows-amd64.zip ...npm ERR! prepareGitDep ngrok - binary downloaded...
npm ERR! prepareGitDep
npm ERR! prepareGitDep 2> npm WARN install Usage of the `--dev` option is deprecated. Use `--only=dev` instead.
npm ERR! prepareGitDep npm WARN deprecated istanbul@0.4.5: This module is no longer maintained, try this instead:
npm ERR! prepareGitDep npm WARN deprecated   npm i nyc
npm ERR! prepareGitDep npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives.
npm ERR! prepareGitDep npm WARN deprecated formatio@1.1.1: This package is unmaintained. Use @sinonjs/formatio instead
npm ERR! prepareGitDep npm WARN deprecated samsam@1.1.2: This package has been deprecated in favour of @sinonjs/samsam
npm ERR! prepareGitDep npm WARN deprecated samsam@1.1.3: This package has been deprecated in favour of @sinonjs/samsam
npm ERR! prepareGitDep npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated istanbul@0.2.16: This module is no longer maintained, try this instead:
npm ERR! prepareGitDep npm WARN deprecated   npm i nyc
npm ERR! prepareGitDep npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives.
npm ERR! prepareGitDep npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm ERR! prepareGitDep npm WARN deprecated tar.gz@1.0.7: ⚠️  WARNING ⚠️ tar.gz module has been deprecated and your application is vulnerable. Please use tar module instead: https://npmjs.com/tar
npm ERR! prepareGitDep npm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.
npm ERR! prepareGitDep npm WARN deprecated connect@2.12.0: connect 2.x series is deprecated
npm ERR! prepareGitDep npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm ERR! prepareGitDep npm WARN deprecated minimatch@0.4.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm ERR! prepareGitDep npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated hoek@0.9.1: The major version is no longer supported. Please update to 4.x or newer
npm ERR! prepareGitDep npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated natives@1.1.6: This module relies on Node.js's internals and will break at some point. Do not use it, and update to graceful-fs@4.x.
npm ERR! prepareGitDep ngrok - error unpacking binary Error: You cannot extract a file outside of the target path
npm ERR! prepareGitDep     at C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\decompress-zip\lib\decompress-zip.js:95:21
npm ERR! prepareGitDep     at Array.map (<anonymous>)
npm ERR! prepareGitDep     at C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\decompress-zip\lib\decompress-zip.js:91:25
npm ERR! prepareGitDep     at _fulfilled (C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\decompress-zip\node_modules\q\q.js:854:54)
npm ERR! prepareGitDep     at C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\decompress-zip\node_modules\q\q.js:883:30
npm ERR! prepareGitDep     at Promise.promise.promiseDispatch (C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\decompress-zip\node_modules\q\q.js:816:13)
npm ERR! prepareGitDep     at C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\decompress-zip\node_modules\q\q.js:624:44
npm ERR! prepareGitDep     at runSingle (C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\decompress-zip\node_modules\q\q.js:137:13)
npm ERR! prepareGitDep     at flush (C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-7d075eca\node_modules\decompress-zip\node_modules\q\q.js:125:13)
npm ERR! prepareGitDep     at processTicksAndRejections (internal/process/task_queues.js:79:9)
npm ERR! prepareGitDep npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules\fsevents):
npm ERR! prepareGitDep npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm ERR! prepareGitDep
npm ERR! prepareGitDep npm ERR! code ELIFECYCLE
npm ERR! prepareGitDep npm ERR! errno 1
npm ERR! prepareGitDep npm ERR! ngrok@2.1.8 postinstall: `node ./postinstall.js`
npm ERR! prepareGitDep npm ERR! Exit status 1
npm ERR! prepareGitDep npm ERR!
npm ERR! prepareGitDep npm ERR! Failed at the ngrok@2.1.8 postinstall script.
npm ERR! prepareGitDep npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! prepareGitDep
npm ERR! prepareGitDep npm ERR! A complete log of this run can be found in:
npm ERR! prepareGitDep npm ERR!     C:\Users\Kristof\AppData\Roaming\npm-cache\_logs\2019-04-08T10_34_11_118Z-debug.log
npm ERR! prepareGitDep
npm timing stage:rollbackFailedOptional Completed in 2ms
npm timing stage:runTopLevelLifecycles Completed in 27576ms
npm verb stack Error: premature close
npm verb stack     at PassThrough.onclose (C:\Users\Kristof\AppData\Roaming\npm\node_modules\npm\node_modules\end-of-stream\index.js:47:67)
npm verb stack     at PassThrough.emit (events.js:198:15)
npm verb stack     at emitCloseNT (internal/streams/destroy.js:68:8)
npm verb stack     at processTicksAndRejections (internal/process/task_queues.js:81:17)
npm verb cwd C:\Users\Kristof\Desktop\Smartbuildings\VisualTeam\pixellair\SmartBuildingsApp\SmartBuildingsApp.Web\SmartBuildingsApp.Web\ClientApp
npm verb Windows_NT 10.0.17763
npm verb argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\Kristof\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "install" "-verbose"
npm verb node v11.13.0
npm verb npm  v6.9.0
npm ERR! premature close
npm verb exit [ 1, true ]
npm timing npm Completed in 30406ms

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Kristof\AppData\Roaming\npm-cache\_logs\2019-04-08T10_34_11_778Z-debug.log
0 Likes

(John Gee) #2

It looks like you are trying npm install on an old package, and lots of its dependencies have been deprecated. Can you look for a newer package, or do you need to try and get it going yourself?

0 Likes

(kristof) #3

i need to use this , can i delete dependencies? and install again ?

grt

update after Mgs 4

0 Likes

(John Gee) #4

You can use npm outdated to show you all the packages that have newer versions. npm update will install the newest version compatible with what is in the package.json and npm update foo will update just foo.

When you have something working it is often easier to update one thing at a time and check for what breaks, but not always possible.

You may need to jump major version, like jumping from v2 to v3, and can do that by reinstalling the package and saying the version number you want like npm install foo@3.

The deprecated packages with the name changes mean uninstalling the old name and reinstalling the new name.

It looks like a pretty big challenge! Good luck.

0 Likes

(kristof) #5

Thank you , i try it but still not working
Outdated shows this.

Package                            Current        Wanted        Latest  Location
@agm/core                          MISSING  1.0.0-beta.5  1.0.0-beta.5  apex
@angular/animations                MISSING         7.2.9        7.2.12  apex
@angular/common                    MISSING         7.2.9        7.2.12  apex
@angular/compiler                  MISSING         7.2.9        7.2.12  apex
@angular/core                      MISSING         7.2.9        7.2.12  apex
@angular/forms                     MISSING         7.2.9        7.2.12  apex
@angular/http                      MISSING         7.2.9        7.2.12  apex
@angular/platform-browser          MISSING         7.2.9        7.2.12  apex
@angular/platform-browser-dynamic  MISSING         7.2.9        7.2.12  apex
@angular/platform-server           MISSING         7.2.9        7.2.12  apex
@angular/router                    MISSING         7.2.9        7.2.12  apex
@ng-bootstrap/ng-bootstrap         MISSING         4.0.0         4.1.1  apex
@ng-select/ng-select               MISSING        2.11.2        2.16.4  apex
@ngrx/store                        MISSING         6.1.0         7.4.0  apex
@ngx-translate/core                MISSING        10.0.2        11.0.1  apex
@ngx-translate/http-loader         MISSING         3.0.1         4.0.0  apex
@swimlane/ngx-charts               MISSING         9.0.0        10.1.0  apex
@swimlane/ngx-datatable            MISSING        13.1.0        14.0.0  apex
@types/chartist                    MISSING        0.9.43        0.9.44  apex
@types/d3-shape                    MISSING         1.2.4         1.3.1  apex
@types/dragula                     MISSING        2.1.33        2.1.34  apex
angular-archwizard                 MISSING         3.0.0         4.0.0  apex
angular-calendar                   MISSING        0.26.3        0.27.2  apex
bootstrap                          MISSING         4.1.3         4.3.1  apex
chartist                           MISSING        0.11.0        0.11.0  apex
classlist.js                       MISSING  1.1.20150312  1.1.20150312  apex
core-js                            MISSING         2.5.7         3.0.1  apex
d3                                 MISSING         5.7.0         5.9.2  apex
datatables.net                     MISSING       1.10.19       1.10.19  apex
date-fns                           MISSING        1.29.0        1.30.1  apex
gulp                               MISSING         4.0.0         4.0.0  apex
hopscotch                          MISSING         0.3.1         0.3.1  apex
intl                               MISSING         1.2.5         1.2.5  apex
ng-chartist                        MISSING         1.1.1         4.1.0  apex
ng2-charts                         MISSING         1.6.0         2.2.2  apex
ng2-completer                      MISSING         2.0.8         2.0.8  apex
ng2-dragula                        MISSING         2.1.0         2.1.1  apex
ng2-file-upload                    MISSING         1.3.0         1.3.0  apex
ng2-img-cropper                    MISSING         0.9.0         0.9.0  apex
ng2-nouislider                     MISSING        1.7.12        1.7.13  apex
ng2-smart-table                    MISSING         1.3.5         1.4.0  apex
ng2-validation                     MISSING         4.2.0         4.2.0  apex
ngx-chips                          MISSING         1.9.8  2.0.0-beta.0  apex
ngx-mqtt                           MISSING         6.9.0         6.9.0  apex
ngx-perfect-scrollbar              MISSING         5.3.5         7.2.1  apex
ngx-quill                          MISSING         4.0.0         4.7.0  apex
ngx-toastr                         MISSING         9.1.1        10.0.2  apex
ngx-ui-switch                      MISSING         7.0.1         8.0.1  apex
node-sass                          MISSING         4.9.4        4.11.0  apex
nouislider                         MISSING        12.0.0        13.1.4  apex
prismjs                            MISSING        1.15.0        1.16.0  apex
quill                              MISSING         1.3.6         1.3.6  apex
resize-observer-polyfill           MISSING         1.5.0         1.5.1  apex
rxjs                               MISSING         6.4.0         6.4.0  apex
screenfull                         MISSING         3.3.3         4.2.0  apex
sweetalert2                        MISSING        7.28.8         8.8.1  apex
tslib                              MISSING         1.9.0         1.9.3  apex
videogular2                        MISSING         6.3.0         6.4.0  apex
web-animations-js                  MISSING         2.2.5         2.3.1  apex
zone.js                            MISSING        0.8.26         0.9.0  apex

the npm install

npm WARN deprecated @angular/http@7.2.9: Switch to @angular/common/http - see https://angular.io/guide/http
npm WARN deprecated core-js@2.5.7: core-js@<2.6.5 is no longer maintained. Please, upgrade to core-js@3 or at least to actual version of core-js@2.
npm ERR! prepareGitDep 1>
npm ERR! prepareGitDep > pre-commit@1.2.2 install C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-77e041ae\node_modules\pre-commit
npm ERR! prepareGitDep > node install.js
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > spawn-sync@1.0.15 postinstall C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-77e041ae\node_modules\spawn-sync
npm ERR! prepareGitDep > node postinstall
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > ngrok@2.1.8 postinstall C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-77e041ae\node_modules\ngrok
npm ERR! prepareGitDep > node ./postinstall.js
npm ERR! prepareGitDep
npm ERR! prepareGitDep ngrok - downloading binary https://bin.equinox.io/a/chRZWPptE7w/ngrok-2.1.1-windows-amd64.zip ...npm ERR! prepareGitDep ngrok - binary downloaded...
npm ERR! prepareGitDep
npm ERR! prepareGitDep 2> npm WARN install Usage of the `--dev` option is deprecated. Use `--only=dev` instead.
npm ERR! prepareGitDep npm WARN deprecated istanbul@0.4.5: This module is no longer maintained, try this instead:
npm ERR! prepareGitDep npm WARN deprecated   npm i nyc
npm ERR! prepareGitDep npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives.
npm ERR! prepareGitDep npm WARN deprecated formatio@1.1.1: This package is unmaintained. Use @sinonjs/formatio instead
npm ERR! prepareGitDep npm WARN deprecated samsam@1.1.2: This package has been deprecated in favour of @sinonjs/samsam
npm ERR! prepareGitDep npm WARN deprecated samsam@1.1.3: This package has been deprecated in favour of @sinonjs/samsam
npm ERR! prepareGitDep npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated istanbul@0.2.16: This module is no longer maintained, try this instead:
npm ERR! prepareGitDep npm WARN deprecated   npm i nyc
npm ERR! prepareGitDep npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives.
npm ERR! prepareGitDep npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm ERR! prepareGitDep npm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.
npm ERR! prepareGitDep npm WARN deprecated connect@2.12.0: connect 2.x series is deprecated
npm ERR! prepareGitDep npm WARN deprecated tar.gz@1.0.7: ⚠️  WARNING ⚠️ tar.gz module has been deprecated and your application is vulnerable. Please use tar module instead: https://npmjs.com/tar
npm ERR! prepareGitDep npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm ERR! prepareGitDep npm WARN deprecated minimatch@0.4.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm ERR! prepareGitDep npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated hoek@0.9.1: The major version is no longer supported. Please update to 4.x or newer
npm ERR! prepareGitDep npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! prepareGitDep npm WARN deprecated natives@1.1.6: This module relies on Node.js's internals and will break at some point. Do not use it, and update to graceful-fs@4.x.
npm ERR! prepareGitDep ngrok - error unpacking binary Error: You cannot extract a file outside of the target path
npm ERR! prepareGitDep     at C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-77e041ae\node_modules\decompress-zip\lib\decompress-zip.js:95:21
npm ERR! prepareGitDep     at Array.map (<anonymous>)
npm ERR! prepareGitDep     at C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-77e041ae\node_modules\decompress-zip\lib\decompress-zip.js:91:25
npm ERR! prepareGitDep     at _fulfilled (C:\Users\Kristof\AppData\Roaming\npm-cache\_cacache\tmp\git-clone-77e041ae\node_modules\decompress-zip\node_modules\q\q.js:854:54)

It’s not so easy :grimacing:

0 Likes

(John Gee) #6

Ah yes, npm outdated is only helpful after you get an install to run! Sorry.

In your first post it looked like your install broke just after natives and mentioned ngrok. I would start researching that package or packages. (But I don’t recognise either.)

0 Likes

(John Gee) #7

I notice there is lots of Angular in the missing packages. Another suggestion is you could try asking in Angular forums/issues page.

0 Likes

(kristof) #8

thank you for the good support

1 Like

(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

0 Likes