error cb() never called error!

What I Wanted to Do

Hi i wanted to use npm install command but always taking this ‘error cb() never called!’ error!

I tried;
remove and install again node.js many many times,
Using npm cache clear --force and npm install --no-package-lock
check environments and control C:\Program Files\nodejs and C:\Users\METASİS\AppData\Roaming\npm

What Happened Instead

Always taking 3032 error cb() never called!
3033 error This is an error with npm itself. Please report this error at:
3034 error https://npm.community

npm version 6.4.1
node version 10.5.1

and end of error detail is

‘C:\Users\METSİS\AppData\Roaming\npm\node_modules.staging\npm-1880f145\bin\npx.cmd’
3030 warn tar ENOENT: no such file or directory, open ‘C:\Users\METSİS\AppData\Roaming\npm\node_modules.staging\npm-1880f145\changelogs\CHANGELOG-1.md’
3031 timing npm Completed in 5665ms
3032 error cb() never called!
3033 error This is an error with npm itself. Please report this error at:
3034 error https://npm.community

Reproduction Steps

Details

Platform Info

$ npm --versions
<!-- paste output here -->
$ node -p process.platform
<!-- paste output here -->

I faced the same issue.

I uninstalled node.
Deleted the nodejs directory.

installed latest nodejs.
after that I did not see the issue.

Now check following –

  1. Always uninstall from Control panel
  2. delete the some left over files from the nodejs directory.
  3. after uninstall, run following two command, just make sure that you do not have multiple copies of nodejs.

node --version.
npm --version

  1. if you are sure that nodejs is not on the system.

I hope this should address your issue.

1 Like

Hi! Faced same problem just now. In the logs I see next:

28862 timing npm Completed in 34536ms
28863 error cb() never called!
28864 error This is an error with npm itself. Please report this error at:
28865 error <https://npm.community>

npm --version
6.9.0
node --version
v10.15.3

1 Like

Hi, I am a linux user and have been using Ubuntu 18.04.2 LTS (bionic). I ran into this issue when I used npx to create my react repo for my react app.
I solved this error message by using sudo to install

sudo npx create-react-app myapp

I hope this could give you another idea for a solution in window (using administrative permission to install or give permission access to npm)
Additional information: node v8.10.0, npm 6.9.0

mee too
happened at Gitlab CI docker

gitlab-runner 11.10.1
Docker with image node:11.15.0-alpine

npm install
(I use node_modules gitlab ci cache, because I want to get .cache dir to speed up slowy build and skip stupid annoying re-installation of node_moudles every build)

Dear npm!
Add please more debug info!

I re-tried with yarn and got:

  1. I had package with github address, so I need git and ssh in my docker image

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.