npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

error 401 when installing eslint

'm trying to install eslint with the following command: npm i -D eslint but I’m getting the following error:

npm i -D eslint
npm ERR! code E401
npm ERR! 401 Unauthorized: @babel/code-frame@^7.0.0

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/carlos/.npm/_logs/2018-11-28T17_08_44_460Z-debug.log

node: v10.13.0
npm: 6.4.1

I have also tried using node 8 and 11 with NPM 6.4.1 and it gives me the same error.


I’m getting the same with all namespaced libraries. And everyone at my company experiences the same issue.

npm ERR! code E401
npm ERR! 404 401 Unauthorized: @zxing/library@^0.8.3

and same with yarn

$ yarn install                                                                                                                                                                                yarn install v1.3.2
[1/4] 🔍  Resolving packages...
error Couldn't find package "@zxing/library" on the "npm" registry.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.


Previous post regarding this: