ENOTEMPTY on removing lodash from .staging folder


(Israel Fruchter) #1

What I Wanted to Do

I’m upgrading my code from node 6.9 to node 8.9.0
hence upgrade npm to latest 6.4.0
I have local packages like
“packageB”: “file:…/packageB”

What Happened Instead

Step 13/18 : RUN cd /tmp/build/${SUB_COMP} && npm --no-package-lock install && npm cache clean --force
—> Running in fc74e806350f
npm WARN deprecated postinstall-build@5.0.2: postinstall-build’s behavior is now built into npm! You should migrate off of postinstall-build and use the new prepare lifecycle script with npm 5.0.0 or greater.
npm WARN deprecated formatio@1.1.1: This package is unmaintained. Use @sinonjs/formatio instead
npm WARN deprecated hoek@2.16.3: The major version is no longer supported. Please update to 4.x or newer
npm WARN tar ENOENT: no such file or directory, open ‘/tmp/build/ingest/node_modules/.staging/iconv-lite-c43e1270/encodings/tables/cp936.json’
npm WARN tar ENOENT: no such file or directory, open ‘/tmp/build/ingest/node_modules/.staging/ajv-4456010e/dist/ajv.min.js.map’
npm WARN tar ENOENT: no such file or directory, open ‘/tmp/build/ingest/node_modules/.staging/linearDataParser-4525da4b/test/test_utils/1050Files/vms_sample_all_3.xml’
npm WARN tar ENOENT: no such file or directory, open ‘/tmp/build/ingest/node_modules/.staging/moment-d1ad770e/min/moment.min.js’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (…/indexer/node_modules/fsevents):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/tmp/build/ingest/node_modules/.staging/fsevents-0377f9f0/node_modules/abbrev’ -> ‘/tmp/build/ingest/node_modules/.staging/abbrev-5181d66d’

npm ERR! path /tmp/build/ingest/node_modules/.staging/lodash-e1ec4318
npm ERR! code ENOTEMPTY
npm ERR! errno -39
npm ERR! syscall rmdir
npm ERR! ENOTEMPTY: directory not empty, rmdir ‘/tmp/build/ingest/node_modules/.staging/lodash-e1ec4318’

Reproduction Steps

Details

Platform Info

root@1684d5ed355b:/# npm --versions
{ npm: '5.5.1',
  ares: '1.10.1-DEV',
  cldr: '31.0.1',
  http_parser: '2.7.0',
  icu: '59.1',
  modules: '57',
  nghttp2: '1.25.0',
  node: '8.9.0',
  openssl: '1.0.2l',
  tz: '2017b',
  unicode: '9.0',
  uv: '1.15.0',
  v8: '6.1.534.46',
  zlib: '1.2.11' }

root@1684d5ed355b:/# node -p process.platform
linux


(system) #2

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.