dependency is not installed because of ETARGET but package is published

website
priority:high
triaged

(Paweł Psztyć) #1

What I Wanted to Do

I’ve updated one of my packages to new version (raml-js-data-provider). I want to install this version in another package (api-console-dev-preview). When calling npm i raml-js-data-provider it throws an error that I fixed in today’s release. So I tried npm i raml-js-data-provider@0.1.2 but I am receiving error:

npm ERR! code ETARGET
npm ERR! notarget No matching version found for raml-js-data-provider@0.1.2
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.

This is interesting because npm view raml-js-data-provider shows:

raml-js-data-provider@0.1.2 | Apache-2.0 | deps: 5 | versions: 3
A npm module to observe API spec folder and generate JavaScript object from RAML for Web Socket server.
https://github.com/advanced-rest-client/raml-js-data-provider#readme

keywords: api-console, builder, node, bower, dependencies

dist
.tarball: https://registry.npmjs.org/raml-js-data-provider/-/raml-js-data-provider-0.1.2.tgz
.shasum: 8c1762503eedb48b7e23553d86c6ed9cdcca3acd
.integrity: sha512-y751232ockWc5y+EubloVtUHtQMyqfBwWmu0flTo456Vsk+6JY8w6elYMp1zHJvsL8t74lwxGQMmOr/kMPndxw==
.unpackedSize: 33.9 kB

dependencies:
fs-extra: ^3.0.0               gulp: 4.0.0                    raml-json-enhance-node: ^0.3.1 winston: ^2.3.1                ws: ^3.1.0                     

maintainers:
- jarrodek <jarrodek@gmail.com>
- mulesoft-npm <mulesoft-npm@mulesoft.com>

dist-tags:
latest: 0.1.2 

I am completely lost here.

What Happened Instead

New version is not installed.

Reproduction Steps

  1. npm i raml-js-data-provider this will fail because of error I was fixing, latest version is not resolved
  2. npm i raml-js-data-provider@0.1.2 This fails because npm see no such version

Details

0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/bin/node',
1 verbose cli   '/usr/local/bin/npm',
1 verbose cli   'i',
1 verbose cli   'raml-js-data-provider@0.1.2' ]
2 info using npm@6.4.1
3 info using node@v8.11.4
4 verbose npm-session 1482501ee56297a9
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 http fetch GET 200 https://registry.npmjs.org/raml-js-data-provider 12ms (from cache)
8 silly registry:manifest no matching version for raml-js-data-provider@0.1.2 in the cache. Forcing revalidation
9 http fetch GET 304 https://registry.npmjs.org/raml-js-data-provider 471ms (from cache)
10 silly fetchPackageMetaData error for raml-js-data-provider@0.1.2 No matching version found for raml-js-data-provider@0.1.2
11 timing stage:rollbackFailedOptional Completed in 1ms
12 timing stage:runTopLevelLifecycles Completed in 1924ms
13 verbose type version
14 verbose stack raml-js-data-provider: No matching version found for raml-js-data-provider@0.1.2
14 verbose stack     at pickManifest (/usr/local/lib/node_modules/npm/node_modules/npm-pick-manifest/index.js:65:11)
14 verbose stack     at fetchPackument.then.packument (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/fetchers/registry/manifest.js:52:18)
14 verbose stack     at tryCatcher (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/util.js:16:23)
14 verbose stack     at Promise._settlePromiseFromHandler (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:512:31)
14 verbose stack     at Promise._settlePromise (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:569:18)
14 verbose stack     at Promise._settlePromise0 (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:614:10)
14 verbose stack     at Promise._settlePromises (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:693:18)
14 verbose stack     at Async._drainQueue (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:133:16)
14 verbose stack     at Async._drainQueues (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:143:10)
14 verbose stack     at Immediate.Async.drainQueues (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:17:14)
14 verbose stack     at runCallback (timers.js:810:20)
14 verbose stack     at tryOnImmediate (timers.js:768:5)
14 verbose stack     at processImmediate [as _immediateCallback] (timers.js:745:5)
15 verbose cwd /Users/ppsztyc/workspace/arc/api-console-dev-preview
16 verbose Darwin 17.7.0
17 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "i" "raml-js-data-provider@0.1.2"
18 verbose node v8.11.4
19 verbose npm  v6.4.1
20 error code ETARGET
21 error notarget No matching version found for raml-js-data-provider@0.1.2
22 error notarget In most cases you or one of your dependencies are requesting
22 error notarget a package version that doesn't exist.
23 verbose exit [ 1, true ]

Platform Info

$ npm --versions
{ 'api-console-dev-preview': '0.1.3',
  npm: '6.4.1',
  ares: '1.10.1-DEV',
  cldr: '32.0',
  http_parser: '2.8.0',
  icu: '60.1',
  modules: '57',
  napi: '3',
  nghttp2: '1.32.0',
  node: '8.11.4',
  openssl: '1.0.2p',
  tz: '2017c',
  unicode: '10.0',
  uv: '1.19.1',
  v8: '6.2.414.54',
  zlib: '1.2.11' }

$ node -p process.platform
darwin

(Lars Willighagen) #2

It seems to be working fine for me right now. There was a related incident not so long ago, does it work again for you?


(Kat Marchán) #3

I will report this internally as a repeat of the ongoing issue. It seems to come and go a lot lately.


(Paweł Psztyć) #4

It seems to be working now. I was able to install published version.