npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

cb() never called error while installing angular/cli

while an installation of angular by npm install -g @angular/cli to get an error:

Error at angular/cli installation:

npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:

npm ERR!

What I Wanted to Do

I want to develop app using angular/cli.

What Happened Instead

but installation of angular/cli itself am getting cb() never called error.

Reproduction Steps

npm install -g @angular/cli

2019-03-02T08_09_02_633Z-debug.log (408.6 KB)

npm version
{ sangitha: ‘1.0.0’,
npm: ‘5.4.2’,
ares: ‘1.10.1-DEV’,
cldr: ‘32.0’,
http_parser: ‘2.8.0’,
icu: ‘60.1’,
modules: ‘57’,
napi: ‘3’,
nghttp2: ‘1.29.0’,
node: ‘8.11.2’,
openssl: ‘1.0.2o’,
tz: ‘2017c’,
unicode: ‘10.0’,
uv: ‘1.19.1’,
v8: ‘6.2.414.54’,
zlib: ‘1.2.11’ }

$ node -p process.platform

Thanks for details. The log shows an error:

5174 warn tar UNKNOWN: unknown error, open ‘C:\Users\Sangitha\AppData\Roaming\npm\node_modules.staging\minimatch-3281beaf\LICENSE’

Do other npm installs work, or do they fail in similar way?

You are running an older version of npm and node, and could try updating if you don’t need to stay on that version.

I also have the same error when trying to npm i in a React app.



To be clear @alexlee-dev, when you say the same error do you refer to

warn tar UNKNOWN: unknown error

or just the final error?

error cb() never called!

(The cb() never called is a symptom and not the underlying error, there is usually another error message.)

Ah, I see. I only got the cb() message.

This is a permissions issue. prepend your commands with “sudo” (without the quotes)

@Nour The original poster is on Windows, so sudo is not relevant.