npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

cb() never called Error on npm install

### What I Wanted to Do
I run “npm install” command to install node_modules.

### What Happened Instead
I got the below error:
$ npm install
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR!

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\A778765\AppData\Roaming\npm-cache_logs\2019-08-19T14_29_59_731Z-debug.log

Full debug.log bel0 info it worked if it ends with ok
0 info it worked if it ends with ok
1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Users\A778765\AppData\Roaming\npm\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘install’ ]
2 info using npm@6.9.0
3 info using node@v10.16.2
4 verbose npm-session be26e3a1677dcb84
5 silly install runPreinstallTopLevelLifecycles
6 silly preinstall Reports@0.4.0
7 info lifecycle Reports@0.4.0~preinstall: Reports@0.4.0
8 silly install loadCurrentTree
9 silly install readLocalPackageData
10 timing stage:loadCurrentTree Completed in 36507ms
11 silly install loadIdealTree
12 silly install cloneCurrentTreeToIdealTree
13 timing stage:loadIdealTree:cloneCurrentTree Completed in 28ms
14 silly install loadShrinkwrap
15 timing stage:loadIdealTree:loadShrinkwrap Completed in 706ms
16 silly install loadAllDepsIntoIdealTree
17 timing npm Completed in 39036ms
18 error cb() never called!
19 error This is an error with npm itself. Please report this error at:
20 error

Platform Info

Win7 64bit

$ npm --versions
{ Reports: ‘0.4.0’,
npm: ‘6.9.0’,
ares: ‘1.15.0’,
brotli: ‘1.0.7’,
cldr: ‘35.1’,
http_parser: ‘2.8.0’,
icu: ‘64.2’,
modules: ‘64’,
napi: ‘4’,
nghttp2: ‘1.34.0’,
node: ‘10.16.2’,
openssl: ‘1.1.1c’,
tz: ‘2019a’,
unicode: ‘12.1’,
uv: ‘1.28.0’,
v8: ‘’,
zlib: ‘1.2.11’ }

$ node -p process.platform

So far, I run below commands
npm cache clean --force
npm install --no-package-lock
npm i --no-package-lock

and I uninstalled node.js and yarn, deleted npm and npm-cache files under appdata, restarted PC and reinstalled npm and yarn.

Still issue occuring.