cb() never called! Bug

What I Wanted to Do

run npm install

What Happened Instead

I got below error
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR! https://npm.community

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\A778765\AppData\Roaming\npm-cache_logs\2019-09-13T18_45_26_348Z-debug.log

and in the log file
0 info it worked if it ends with ok
1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘install’ ]
2 info using npm@6.9.0
3 info using node@v10.16.3
4 verbose npm-session 0218bc583a1bc0e5
5 silly install runPreinstallTopLevelLifecycles
6 silly preinstall nexus-launch@0.1.0
7 info lifecycle nexus-launch@0.1.0~preinstall: nexus-launch@0.1.0
8 silly install loadCurrentTree
9 silly install readLocalPackageData
10 timing stage:loadCurrentTree Completed in 41ms
11 silly install loadIdealTree
12 silly install cloneCurrentTreeToIdealTree
13 timing stage:loadIdealTree:cloneCurrentTree Completed in 1ms
14 silly install loadShrinkwrap
15 timing stage:loadIdealTree:loadShrinkwrap Completed in 4ms
16 silly install loadAllDepsIntoIdealTree
17 timing npm Completed in 11697ms
18 error cb() never called!
19 error This is an error with npm itself. Please report this error at:
20 error https://npm.community

Reproduction Steps

In my case running npm install on any react app gives this error

Platform Info

Win7 Visual Code

$ npm --versions
{ 'nexus-launch': '0.1.0',
  npm: '6.9.0',
  ares: '1.15.0',
  brotli: '1.0.7',
  cldr: '35.1',
  http_parser: '2.8.0',
  icu: '64.2',
  modules: '64',
  napi: '4',
  nghttp2: '1.39.2',
  node: '10.16.3',
  openssl: '1.1.1c',
  tz: '2019a',
  unicode: '12.1',
  uv: '1.28.0',
  v8: '6.8.275.32-node.54',
  zlib: '1.2.11' }


$ node -p process.platform
win32

Hi I have similar error and same verison of npm , please see the log as shown below.

I try npm install and keep getting this error:

cb() never called!
npm ERR! This is an error with npm itself. Please report this error at:

LOG FILE:
0 info it worked if it ends with ok
1 verbose cli [
1 verbose cli ‘/usr/local/Cellar/node/12.6.0/bin/node’,
1 verbose cli ‘/usr/local/bin/npm’,
1 verbose cli ‘install’,
1 verbose cli ‘npm@latest’,
1 verbose cli ‘-g’
1 verbose cli ]
2 info using npm@6.9.0
3 info using node@v12.6.0
4 verbose npm-session ae05d2ef5606e013
5 silly install loadCurrentTree
6 silly install readGlobalPackageData
7 timing npm Completed in 256ms
8 error cb() never called!
9 error This is an error with npm itself. Please report this error at:
10 error https://npm.community

@Nik16
The “cb() never called!” is a generic error and not the underlying cause. You are on a different operating system trying a different install, and likely to be a different problem. I suggest you open a new topic with your issue.

1 Like