npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

can't publish new version of package

hi!

so about an hour ago i published a new revision (v.0.0.20) of my package. i got an email about it and i can see the new version on my packages page on https://www.npmjs.com/settings/edwardsharp/packages but for some reason the package doesn’t actually seem published because the package page is still showing the old version (v0.0.19) https://www.npmjs.com/package/@edwardsharp/a-player

so, i tried to publish a new version (0.0.21& 0.0.22) but i am getting 2FA errors: npm ERR! publish Failed PUT 401 (i then also noticed that this happened in the first place)

i’m not sure what’s wrong? i tried to disable my 2FA auth and try to publish again but i get an error:

npm ERR! publish Failed PUT 404
npm ERR! code E404
npm ERR! 404 tfa not enabled : @edwardsharp/a-player
npm ERR! 404
npm ERR! 404 ‘@edwardsharp/a-player’ is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)

…help?

EDIT: i disabled & reenabled 2FA and tried to publish again, but still seeing old (0.0.19) version on the package page (but still getting emails & new versions listed on settings page)

EDIT 2: i see the issue and am tracking via https://status.npmjs.org/incidents/gzg16mxb67nw


my package is now published! <3


This is a duplicate of "Npm publish" hangs and never finishes