npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

Can't install node-fetch

What I Wanted to Do

npm i node-fetch

What Happened Instead

npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR!     <>

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\ninof\AppData\Roaming\npm-cache\_logs\2019-02-13T22_35_18_668Z-debug.log

Reproduction Steps

cf above


2019-02-13T22_38_27_363Z-debug.log (156,5 Ko)

Platform Info

$ npm --versions
{ 'ig-data': '1.2.1',
  npm: '6.4.1',
  ares: '1.14.0',
  cldr: '33.1',
  http_parser: '2.8.0',
  icu: '62.1',
  modules: '67',
  napi: '3',
  nghttp2: '1.34.0',
  node: '11.0.0',
  openssl: '1.1.0i \n',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.23.2',
  v8: '',
  zlib: '1.2.11' }
$ node -p process.platform

Are there any Unhandled rejections? This error unfortunately doesn’t tell us much. Also, can you try this:

I typed the same command in the same directory five minutes after are from another shell (cmd instead of powershell) and it worked as expected :slight_smile: still not sure why this happened though