Can't include local versions of angular-datatables and angular-6-datatable-cc

I cloned angular-6-datatable-cc and added “angular-6-datatable-cc”: “file:…/…/…/…/angular-6-datatable”.
npm install generates lib directory under node_modules/angular-6-datatables-cc when specifying version but not when using local, and that caused an issue, so I manually copied over the lib directory but I’m just having a ton of issues here.

from

    "angular-6-datatable-cc": "^0.8.1",
    "angular-datatables": "^7.0.0",

to

"angular-6-datatable-cc": "file:../../../../dt6",
"angular-datatables": "file:../../../../angular-datatables",

then I upgrade packages in dt6, and I just get a bunch of errors from ng that it’s still depending on angular 6 not 8. I just don’t know what to do. I feel like I’ve tried every possible combination of npm installing, then going and upgrading the other packages or the other way around, or cheating by creating an old version of of -cc by renaming it dt6, and then swapping out the directory.
I’m posting here in case anyone has general advice. I’m going to now work on a minimal example.

git clone git@github.com:aslam2368/angular-6-datatable.git
cd angular-6-datatable
>> ng update @angular/cli @angular/core
Cannot find module '@angular-devkit/schematics'

(You might get an answer here, but because this forum is focused on npm, you might want to ask your question somewhere that targets experts with Angular. I have moved your topic to #community:javascript)

I found a couple of reports with the error in your reproduce steps, although different command. Might help:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.