Access to ecstatic previous versions

(Sebastien Crespin) #1

Hi,

It seems that previous versions (before current one 4.1.2) are not available anymore in the version history.

Is it normal? Can we have back the old versions?
Since today we have errors in our code dev build job because of ecstatic 2.0.0 not available so I guess it could be related.

npm ERR! notarget No compatible version found: ecstatic@^2.0.0
npm ERR! notarget Valid install targets:
npm ERR! notarget 4.1.2
npm ERR! notarget 
npm ERR! notarget This is most likely not a problem with npm itself.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! notarget 
npm ERR! notarget It was specified as a dependency of 'http-server'
npm ERR! notarget 

Thanks for your support
Regards

(Sebastien Crespin) #2

I just saw this issue on the ecstatic Github

Some other people have the same issue as me.
I guess we should follow the topic on the Github issue.

Thanks
Regards

1 Like
(John Gee) #3

From reading the linked thread, looks like it may have been a deliberate (if unfortunate) decision by node-estatic owners rather than an issue with the registry.

(Sebastien Crespin) #4

Yes it was because of a security issue fixed only in version 4. But now versions 3 and 2 are upgraded as well and available again. So issue is fixed from my point of view.

$ npm view ecstatic versions --json
[
  "2.2.2",
  "3.3.2",
  "4.1.2"
]

Thanks

(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.