6.9.0: npm up: "not implemented yet"

(Christopher Boyd) #1

What I Wanted to Do

I tried to run npm up in my project.

What Happened Instead

npm up fails in my project.

Reproduction Steps

I’m not really sure. It works fine if I downgrade back to npm 6.8.0. It also works fine if I do a global upgrade.

In addition, I tried deleting my node_modules folder and npm i worked fine, but a subsequent npm up failed with the same error message.

Details

Here’s a copy of the log: 2019-03-17T01_22_23_989Z-debug.log (9.2 KB)

Platform Info

$ npm --versions
{ npm: '6.9.0',
  ares: '1.15.0',
  brotli: '1.0.7',
  cldr: '34.0',
  http_parser: '2.8.0',
  icu: '63.1',
  llhttp: '1.1.1',
  modules: '67',
  napi: '4',
  nghttp2: '1.34.0',
  node: '11.11.0',
  openssl: '1.1.1a',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.26.0',
  v8: '7.0.276.38-node.18',
  zlib: '1.2.11' }
$ node -p process.platform
darwin
npm outdated --> Error: "Not implemented yet"
(Tristan Hall) #2

I am also seeing this error.
I’ve tried removing the local node_modules directory, force cleaned the cache, and re-installing the local node_modules directory.

Log file: 2019-03-22T16_37_42_231Z-debug.log (10.0 KB)

Platform Info

$ npm --versions
{ 'mms-internal': '1.0.0',
  npm: '6.9.0',
  ares: '1.15.0',
  brotli: '1.0.7',
  cldr: '34.0',
  http_parser: '2.8.0',
  icu: '63.1',
  llhttp: '1.1.1',
  modules: '67',
  napi: '4',
  nghttp2: '1.34.0',
  node: '11.11.0',
  openssl: '1.1.1a',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.26.0',
  v8: '7.0.276.38-node.18',
  zlib: '1.2.11' }
$ node -p process.platform
darwin
(Lars Willighagen) #3

I reproduced this. git bisect gives me

which makes sense, that’s a pretty big update. I’ll see what I can do.

2 Likes
(Tristan Hall) #4

Thank you very much!

(Lars Willighagen) #5

PR:

1 Like
(Spyshower) #6

Are we going to get an update soon?

(Pavel) #7

Strange that this is not yet fixed. I have to use npm 6.8.0, this bug is still present in 6.9.1-next.0.