💡 ideas


Topic Replies Activity
need a dependencies field when already exists in global, then skip install 2 May 28, 2019
Any way to sync audit data to private local registry? 3 May 27, 2019
Cannot set npm config keys containing underscores (registry auth tokens, for example) via npm_config_ environment variables 12 May 27, 2019
Support semver build metadata in package versions 2 May 21, 2019
NPM Needs a more robust story for local multi-module development 12 May 21, 2019
Yarn resolutions equivalent 4 May 18, 2019
NPM audit for multiple subfolders 1 May 16, 2019
Registry Search API: Return Exact Match for Short Queries 2 May 14, 2019
Global install fails for @superflycss/cli - Missing write access to node_modules/fsevents/node_modules/abbrev 2 May 10, 2019
NPM CLI support for Windows 10 on ARM 4 May 9, 2019
Improve security vulnerabilities interaction 2 May 8, 2019
publish --dry-run result in a failure if version already published 3 May 6, 2019
Show security vulnerabilities, ask for consent before installing something on the user's computer 1 May 4, 2019
`npm outdated` does not suggest latest tag for git URLs 1 April 30, 2019
Let specify starting code to open in RunKit 1 April 30, 2019
Aborting the publish when got any options which are illegal 1 April 27, 2019
"Last Published" timestamp not related to official version 3 April 24, 2019
we need a new devPackageDependencies field in package.json 4 April 23, 2019
npm outdated command does not separate dependencies and dev dependencies 2 April 22, 2019
Let npm scripts change environment of the current shell (to run scripts in a current shell, instead of a subshell) 4 April 19, 2019
Request to change "I sure hope you know what you are doing" warning message... 5 April 27, 2019
Should npm run as unprivileged setuid? 1 April 19, 2019
npm performance on Windows 1 April 18, 2019
Set rel=canonical on ?activeTab=readme links 1 April 16, 2019
`npm r` as shortcut for `npm run` 1 April 16, 2019
Trust the system root CA certificates 2 April 11, 2019
npmjs.com should display latest GA version if current version is a prerelease 5 April 9, 2019
`npm install somePackage@latest` should be able to be told to only install GA releases 5 April 9, 2019
Standardize a `changes` log property for pointing to CHANGES.md, HISTORY, etc. 3 April 8, 2019
conditional things for the readme maybe? 1 April 6, 2019